Advertisement

header ads

Tutor LMS < 1.9.11 - Stored Cross-Site Scripting

 

Estaba jugando con un sitio de mi mejor amigo y encontre que existia una vulnerabilidad por medio de su plugin.

¿Qué es Tutor LMS?

Tutor es un plugin de WordPress LMS completo, completo y robusto para crear y vender cursos en línea fácilmente. Todas las características de este sistema de gestión del aprendizaje alcanzan todos los puntos de control para un mercado de cursos en línea completo. Puede crear cuestionarios desafiantes y divertidos, lecciones interactivas, informes y estadísticas potentes, lo que hace que Tutor sea potencialmente el mejor plugin gratuito de WordPress LMS. Administra y monetiza su educación, escuela en línea y cursos en línea sin tener que escribir una sola línea de código.
LINK: Tutor LMS

¿Como encontre esta vulnerabilidad?

Este plugin se encuentra en la versión 1.9.11.
El mismo plugin crea un registro para poder acceder a sus cursos programados.

 

Con una cuenta registrada puedo acceder por medio de un perfil de wordpress.
Ruta: [wp-admin/profile.php]

Este plugin crea una configuración llamada "Tutor Fields" donde se encuentra en el perfil del usuario creado por medio de este plugin, la opción "Job Title" tiene esta vulnerabilidad donde se logra inyectar codigo en "_tutor_profile_job_title" y queda guardado en la base de datos.

 

Por medio a XSS de OWASP tuve la opción de poder encontrar esta vulnerabilidad.

 

Nos permite poder cerrar en comillas y poder seguir injectando codigo, en la imagen podemos observar un ejemplo.

Asi logramos encontrar esta vulnerabilidad donde se queda guardado en la base de datos.


¿Qué tipo de versión es vulnerable?

Versión vulnerable del plugin: 1.9.9, 1.9.10, 1.9.11


 

Publicar un comentario

0 Comentarios